summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-15 15:22:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-15 15:22:12 +0200
commit6737d8d3248301e65bc24291b1a776e4aa8c3648 (patch)
tree389ea2355bc7cbb2e0a13dab074f90d1a8f53de5 /gnu
parentc8accb5eb6cd911dc913d1054418a9e94d27344c (diff)
gnu: Add r-snftool.
* gnu/packages/cran.scm (r-snftool): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3312c2d102..5cdb37075e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9133,6 +9133,30 @@ and rows. The fst format allows for random access of stored data and
compression with the LZ4 and ZSTD compressors.")
(license license:agpl3)))
+(define-public r-snftool
+ (package
+ (name "r-snftool")
+ (version "2.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "SNFtool" version))
+ (sha256
+ (base32
+ "05hz230aq5wbzhknxzr4iqv3nqjhbpf66n6bp1rc5h2jgz2yfbwq"))))
+ (properties `((upstream-name . "SNFtool")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-alluvial r-exposition))
+ (home-page "https://cran.r-project.org/package=SNFtool")
+ (synopsis "Similarity network fusion")
+ (description
+ "Similarity Network Fusion takes multiple views of a network and fuses
+them together to construct an overall status matrix. The input to our
+algorithm can be feature vectors, pairwise distances, or pairwise
+similarities. The learned status matrix can then be used for retrieval,
+clustering, and classification.")
+ ;; Any version of the GPL
+ (license license:gpl3+)))
+
(define-public r-snowfall
(package
(name "r-snowfall")