summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@gmail.com>2020-05-29 18:35:55 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-31 23:31:04 +0200
commit6c3d3f2949278055124f5070112b4149b8105503 (patch)
tree7b8e369ae767340e6c6cba780697e825ee10eb44 /gnu
parent115a1ed2b84006a409811605ba818ce599082401 (diff)
gnu: Add emacs-buffer-move.
* gnu/packages/emacs-xyz.scm (emacs-buffer-move): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4a2452577c..7c014cfd4c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -73,6 +73,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
+;;; Copyright © 2020 Fredrik Salomonsson <plattfot@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22457,6 +22458,29 @@ text, such a marking style might be used to show externally included text or
example code.")
(license license:gpl3+))))
+(define-public emacs-buffer-move
+ (package
+ (name "emacs-buffer-move")
+ (version "0.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lukhas/buffer-move.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xdks4jfqyhkh34y48iq3gz8swp0f526kwnaai5mhgvazvs4za8c"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/lukhas/buffer-move")
+ (synopsis "Functions for moving Emacs' buffers around")
+ (description
+ "This package define functions for swapping buffers between windows
+contained in the same frame. An alternate behavior is to have the current
+window switch to the previous buffer instead of swapping with the other
+window.")
+ (license license:gpl3+)))
+
(define-public emacs-company-ebdb
(package
(name "emacs-company-ebdb")