summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 10:54:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:56 +0100
commit7f960d81fb8685e707b6805e1ac00da63f39407c (patch)
treed943aa8b6ae0a3c60fe4e1e340a44730d8b821d7 /gnu
parent402dae07b5a8baa5d99d6d8e39b3917d0706b9b7 (diff)
gnu: Add r-activedriver.
* gnu/packages/cran.scm (r-activedriver): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6efd1a66c2..00ce9ad934 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17963,3 +17963,31 @@ examples.")
"This package provides tools for functional linear modeling and analysis
of actigraphy data.")
(license license:asl2.0)))
+
+(define-public r-activedriver
+ (package
+ (name "r-activedriver")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ActiveDriver" version))
+ (sha256
+ (base32
+ "10c7ga48fwvpd5mc4dqiyw4kc2l0iz5qn4hg7xk15r1qmm5rsipa"))))
+ (properties `((upstream-name . "ActiveDriver")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)))
+ (home-page "https://cran.r-project.org/web/packages/ActiveDriver/")
+ (synopsis "Tools for finding cancer driver proteins")
+ (description
+ "This package provides a mutation analysis tool that discovers cancer
+driver genes with frequent mutations in protein signalling sites such as
+post-translational modifications (phosphorylation, ubiquitination, etc). The
+Poisson generalized linear regression model identifies genes where cancer
+mutations in signalling sites are more frequent than expected from the
+sequence of the entire gene. Integration of mutations with signalling
+information helps find new driver genes and propose candidate mechanisms to
+known drivers.")
+ (license license:gpl2+)))