summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-09-29 09:58:05 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-10-19 22:42:36 +0200
commit80641727edb02b0665085367686289c8a07c13c6 (patch)
treebccf42c09a53684a913f2b60269b3bb0ab9e3436 /gnu
parent4d850f7c5a1ec773ef1d12dce4c1e1000819920d (diff)
gnu: Add emacs-graphql-mode.
* gnu/packages/emacs-xyz.scm (emacs-graphql-mode): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7befae0b3..5acb8ce6ec 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -768,6 +768,34 @@ GraphQL is a data query language and runtime designed and used to request and
deliver data to mobile and web apps.")
(license license:gpl3+)))
+(define-public emacs-graphql-mode
+ ;; No tagged commit.
+ (let ((commit "9bed568ec86242dbe30bdbab324aa0eb2cd9bf08")
+ (revision "1"))
+ (package
+ (name "emacs-graphql-mode")
+ (version commit)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davazp/graphql-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x9y7qq6y0zg8ncamzvk68ccmdyzh7xsj0xs0ykyl20d5wdpplj4"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/davazp/graphql-mode")
+ (synopsis "Emacs mode to edit GraphQL schema and queries")
+ (description
+ "This package implements a major mode to edit GraphQL schemas and
+query. The basic functionality includes syntax highlight and indentation.
+Additionally, it is able to send GraphQL queries to an end-point URL.
+
+Files with the @file{.graphql} and @file{.gql} extensions are
+automatically opened with this mode.")
+ (license license:gpl3+))))
+
(define-public emacs-ghub
(package
(name "emacs-ghub")