summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-15 13:51:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-15 13:51:58 +0100
commit9904a15a4c838362673c1affdbaf1e83d92fe8ff (patch)
tree2c6d3ee3ab59e1af5b3b2d6c0bb3798d8aeb0eb5 /gnu
parent8116c9d77dc3b07fa3ccfbda21da0cdf883441c2 (diff)
gnu: Add indelfixer.
* gnu/packages/bioinformatics.scm (indelfixer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6f835b3875..f3e0e41e4d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15570,6 +15570,41 @@ manipulation of hierarchical features (e.g., genes, transcripts, and exons)
than is possible with plain-text methods alone.")
(license license:expat))))
+(define-public indelfixer
+ (package
+ (name "indelfixer")
+ (version "1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cbg-ethz/InDelFixer/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10ak05x8i1bx2p7rriv2rglqg1wr7c8wrhjrqlq1wm7ka99w8i79"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "InDelFixer.jar"
+ #:source-dir "src/main/java"
+ #:test-dir "src/test"))
+ (inputs
+ `(("java-commons-lang2" ,java-commons-lang)
+ ("java-args4j" ,java-args4j)))
+ (native-inputs
+ `(("java-junit" ,java-junit)))
+ (home-page "https://github.com/cbg-ethz/InDelFixer/")
+ (synopsis "Iterative and sensitive NGS sequence aligner")
+ (description "InDelFixer is a sensitive aligner for 454, Illumina and
+PacBio data, employing a full Smith-Waterman alignment against a reference.
+This Java command line application aligns Next-Generation Sequencing (NGS) and
+third-generation reads to a set of reference sequences, by a prior fast k-mer
+matching and removes indels, causing frame shifts. In addition, only a
+specific region can be considered. An iterative refinement of the alignment
+can be performed, by alignment against the consensus sequence with wobbles.
+The output is in SAM format.")
+ (license license:gpl3+)))
+
(define-public libsbml
(package
(name "libsbml")