summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 13:31:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:57 +0100
commit9906cb80de8e2bcfc55507d6c6f00fc3a89000b3 (patch)
tree541f19b9b69a4edfd371a5647094b64c5155582d /gnu
parent94ecf71344bc55fa2610d45f391a21befdfb54f7 (diff)
gnu: Add r-flexclust.
* gnu/packages/cran.scm (r-flexclust): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0aa20b8e6e..3cd12d185c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18426,3 +18426,32 @@ Visualizations are also available for most of these settings.")
"This package provides an implementation of the Tukey, Mandel,
Johnson-Graybill, LBI, Tusell and modified Tukey non-additivity tests.")
(license license:gpl3)))
+
+(define-public r-flexclust
+ (package
+ (name "r-flexclust")
+ (version "1.4-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "flexclust" version))
+ (sha256
+ (base32
+ "0x7wxk8y46ndyz6fdacym0rd6p9wh3pcfr28chjcg5d7fm849zl2"))))
+ (properties `((upstream-name . "flexclust")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-class" ,r-class)
+ ("r-lattice" ,r-lattice)
+ ("r-modeltools" ,r-modeltools)))
+ (home-page "https://cran.r-project.org/web/packages/flexclust/")
+ (synopsis "Flexible cluster algorithms")
+ (description
+ "The main function @code{kcca} implements a general framework for
+k-centroids cluster analysis supporting arbitrary distance measures and
+centroid computation. Further cluster methods include hard competitive
+learning, neural gas, and QT clustering. There are numerous visualization
+methods for cluster results (neighborhood graphs, convex cluster hulls,
+barcharts of centroids, ...), and bootstrap methods for the analysis of
+cluster stability.")
+ (license license:gpl2)))