summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-09-21 22:44:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-09-25 21:44:29 +0200
commit9a49a5351cdde7a02b57a9491c5de82ad5317485 (patch)
treeed42acb92b31a3823e153f9ab2c6b8a68bc4a190 /gnu
parentd708b7a9734e5a2b2bd9db6152b2584e01086517 (diff)
gnu: Add python-ipaddress.
* gnu/packages/python.scm (python2-ipaddress): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 40d31a70e3..025f3b49fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4939,3 +4939,28 @@ suitable for a wide range of protocols based on the ASN.1 specification.")
(define-public python2-pyasn1
(package-with-python2 python-pyasn1))
+
+(define-public python2-ipaddress
+ (package
+ (name "python2-ipaddress")
+ (version "1.0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/i/"
+ "ipaddress/ipaddress-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0givid4963n57nsjibms2fc347zmcs188q1hw9al1dkc9kj4nvr2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:python ,python-2))
+ (home-page "https://github.com/phihag/ipaddress")
+ (synopsis "IP address manipulation library")
+ (description
+ "This package provides a fast, lightweight IPv4/IPv6 manipulation library
+in Python. This library is used to create, poke at, and manipulate IPv4 and
+IPv6 addresses and networks. This is a port of the Python 3.3 ipaddress
+module to older versions of Python.")
+ (license psfl)))