summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-14 15:37:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-14 15:43:41 +0200
commitaa5df43668b63993ef6153789b67ab1b040ddb84 (patch)
tree4b4a0cda4ea85691e0f23e10f9ed02a67feef7b0 /gnu
parent2fc6d733f31e497f6a23cc8f14936bd66bc87831 (diff)
gnu: imposm3: Don't use autogenerated tarball.
* gnu/packages/geo.scm (imposm3)[source]: Download using git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/geo.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 9895756864..2e5315faff 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018, 2019, 2020, 2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2021 Wiktor Żelazny <wzelazny@vurv.cz>
;;; Copyright © 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
@@ -1260,13 +1260,14 @@ delivered to any client.")
(version "0.11.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/omniscale/imposm3/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/omniscale/imposm3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1w7b221z5k9254zn01imycxkyw62xigqizhwvrgxqmq1m9r5410l"))))
+ "1ifniw57l3s0sl7nb3zwxxm86i46451yrhfqnnkxr46cnpbzmwxr"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/omniscale/imposm3/cmd/imposm"