summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-05-30 21:27:49 +0200
committerMarius Bakke <marius@gnu.org>2020-05-30 23:19:51 +0200
commitaba53e7013aff6c978fafffbd7223365b56963c7 (patch)
tree013253a9bf01f3258403b38e112adba1b7ef2709 /gnu
parenta8c7d4b0c326905b71680783ced6b68d25fb3bfd (diff)
gnu: python-astroid: Update to 2.4.1.
* gnu/packages/python-xyz.scm (python-astroid): Update to 2.4.1. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index baec999247..79816ddc2f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -80,6 +80,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13905,13 +13906,13 @@ clone, while other processes access the original tree.")
(define-public python-astroid
(package
(name "python-astroid")
- (version "2.3.3")
+ (version "2.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astroid" version))
(sha256
- (base32 "0fnibsl2cb5mvzbfm7sycj85smx48f8w8m7ks1sqlmpr9ps0gski"))))
+ (base32 "1h99jal7ax07xna1djw5z7hpgb8vjrl3hrrg49p1phljwniww5sc"))))
(build-system python-build-system)
(propagated-inputs
`(("python-lazy-object-proxy" ,python-lazy-object-proxy)
@@ -13923,19 +13924,6 @@ clone, while other processes access the original tree.")
("python-nose" ,python-nose)
("python-pytest" ,python-pytest)
("python-pytest-runner" ,python-pytest-runner)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-spurious-test
- (lambda _
- ;; This can be removed after upgrading from python-3.7
- ;; https://github.com/PyCQA/astroid/issues/593
- ;; https://bugs.python.org/issue34056
- (delete-file "astroid/tests/unittest_modutils.py")
- #t))
- (replace 'check
- (lambda _
- (invoke "pytest" "astroid"))))))
(home-page "https://github.com/PyCQA/astroid")
(synopsis "Common base representation of python source code for pylint and
other projects")