summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:18:25 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commitacbb40fa2076c13aefa43c9d92474481cef110e4 (patch)
treedcec7ffe5b732b78a8bad69a70db2d9e4b646765 /gnu
parentad3f005bddcca58c9f4869fffb8aef0cf4efb598 (diff)
gnu: Add r-mime.
* gnu/packages/statistics.scm (r-mime): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 5cf094c0ee..82a1fb8291 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -619,3 +619,21 @@ There is also a Shiny app as a user interface in this package.")
it supports LaTeX and HTML output. Source code of other languages is
supported via Andre Simon's highlight package.")
(license license:gpl3+)))
+
+(define-public r-mime
+ (package
+ (name "r-mime")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mime" version))
+ (sha256
+ (base32
+ "145cdcg252w2zsq67dmvmsqka60msfp7agymlxs3gl3ihgiwg46p"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/yihui/mime")
+ (synopsis "R package to map filenames to MIME types")
+ (description
+ "This package guesses the MIME type from a filename extension using the
+data derived from /etc/mime.types in UNIX-type systems.")
+ (license license:gpl2)))