summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-10-17 21:42:42 +0200
committerAndreas Enge <andreas@enge.fr>2015-12-08 23:09:59 +0100
commitb00150641a6949b71304b9e6ec85d74f3cab2687 (patch)
tree855ef65976f28511d3c256e8b296f5b83ffdd0fe /gnu
parentc4991257047f5969946da387cbeee10e2db4e6ab (diff)
gnu: numactl: Update to 2.0.10.
* gnu/packages/linux.scm (numactl)[source]: Update to 2.0.10. [arguments]: Adapt phases to use the autotools machinery. [native-inputs]: Add autotools packages.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm38
1 files changed, 13 insertions, 25 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6ffd7e1864..27fa383f14 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1392,7 +1392,7 @@ file system is as easy as logging into the server with an SSH client.")
(define-public numactl
(package
(name "numactl")
- (version "2.0.9")
+ (version "2.0.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1401,35 +1401,23 @@ file system is as easy as logging into the server with an SSH client.")
".tar.gz"))
(sha256
(base32
- "073myxlyyhgxh1w3r757ajixb7s2k69czc3r0g12c3scq7k3784w"))))
+ "0qfv2ks6d3gm0mw5sj4cbhsd7cbsb7qm58xvchl2wfzifkzcinnv"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(arguments
- '(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; There's no 'configure' script, just a raw makefile.
- (substitute* "Makefile"
- (("^prefix := .*$")
- (string-append "prefix := " (assoc-ref outputs "out")
- "\n"))
- (("^libdir := .*$")
- ;; By default the thing tries to install under
- ;; $prefix/lib64 when on a 64-bit platform.
- (string-append "libdir := $(prefix)/lib\n"))))
- %standard-phases)
-
- #:make-flags (list
- ;; By default the thing tries to use 'cc'.
- "CC=gcc"
-
- ;; Make sure programs have an RPATH so they can find
- ;; libnuma.so.
- (string-append "LDLIBS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib"))
-
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'unpack 'autogen
+ (lambda _
+ (zero? (system* "sh" "autogen.sh")))))
;; There's a 'test' target, but it requires NUMA support in the kernel
;; to run, which we can't assume to have.
#:tests? #f))
+
(home-page "http://oss.sgi.com/projects/libnuma/")
(synopsis "Tools for non-uniform memory access (NUMA) machines")
(description