summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-04 14:50:37 +0200
committerRoel Janssen <roel@gnu.org>2018-04-04 14:50:37 +0200
commitb028a9830c5652c1c1782655c4cf268f4de7cc89 (patch)
treea9f366fd9afd44401541c73100237d9af17931b7 /gnu
parent03efe78c3483ea046fd050bf9b6eeadee08e7236 (diff)
gnu: Add perl-pathtools.
* gnu/packages/perl.scm (perl-pathtools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8cb584c30d..9676920e17 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6655,6 +6655,36 @@ up inheritance from those modules at the same time.")
directory specifications in a cross-platform manner.")
(license (package-license perl))))
+(define-public perl-pathtools
+ (package
+ (name "perl-pathtools")
+ (version "3.74")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/X/XS/XSAWYERX/PathTools-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "04bfjdvn5p78hirljcinpxv8djcjn8nyg5gcmnmvz8sr9k2lqwi5"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-pwd-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "Cwd.pm"
+ (("'/bin/pwd'")
+ (string-append "'" (assoc-ref inputs "coreutils")
+ "/bin/pwd'"))))))))
+ (inputs
+ `(("coreutils" ,coreutils)))
+ (home-page "http://search.cpan.org/dist/PathTools/")
+ (synopsis "Tools for working with directory and file names")
+ (description "This package provides functions to work with directory and
+file names.")
+ (license perl-license)))
+
(define-public perl-path-tiny
(package
(name "perl-path-tiny")