summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-31 15:43:12 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-14 14:53:31 +0200
commitb783ff7833df1cb5284139ed80a00826b5dc93fd (patch)
tree575e7eceaadf79866ecf4d41433bb85de0a710a5 /gnu
parent790034bd23a569c00960ac9f2c86b1b045adb653 (diff)
gnu: Add r-nmf.
* gnu/packages/statistics.scm (r-nmf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d337e15df8..b234517f9d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2120,6 +2120,44 @@ for reproducibility. Notably, convenient default methods greatly facilitate
the way current RNG settings can be changed.")
(license license:gpl3+)))
+(define-public r-nmf
+ (package
+ (name "r-nmf")
+ (version "0.20.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "NMF" version))
+ (sha256
+ (base32
+ "0mmh9bz0zjwd8h9jplz4rq3g94npaqj8s4px51vcv47csssd9k6z"))))
+ (properties `((upstream-name . "NMF")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cluster" ,r-cluster)
+ ("r-colorspace" ,r-colorspace)
+ ("r-digest" ,r-digest)
+ ("r-doparallel" ,r-doparallel)
+ ("r-foreach" ,r-foreach)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridbase" ,r-gridbase)
+ ("r-pkgmaker" ,r-pkgmaker)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-registry" ,r-registry)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rngtools" ,r-rngtools)
+ ("r-stringr" ,r-stringr)))
+ (home-page "http://renozao.github.io/NMF")
+ (synopsis "Algorithms and framework for nonnegative matrix factorization")
+ (description
+ "This package provides a framework to perform Non-negative Matrix
+Factorization (NMF). The package implements a set of already published
+algorithms and seeding methods, and provides a framework to test, develop and
+plug new or custom algorithms. Most of the built-in algorithms have been
+optimized in C++, and the main interface function provides an easy way of
+performing parallel computations on multicore machines.")
+ (license license:gpl2+)))
+
(define-public r-r-methodss3
(package
(name "r-r-methodss3")