summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-09-15 19:57:48 -0400
committerLeo Famulari <leo@famulari.name>2020-09-15 23:21:57 -0400
commitcca5720f410ce01e2b3ed7e4fde593e118f08f07 (patch)
tree774cfe81fc0000b8752e72aebb66e91299b996c2 /gnu
parent3c9294c05fa0c57884c94f809f3f9762b6f55f85 (diff)
gnu: Fix fetching the linux-libre deblobbing script.
This is a followup to commit 105a037090d9a970a2c2336341d6673eff29e4cf. * gnu/packages/linux.scm (linux-libre-deblob-scripts): Truncate the version in the file-name, not the source URI.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 59ffb334e0..2e47b81cf6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -195,9 +195,9 @@ defconfig. Return the appropriate make target if applicable, otherwise return
(method url-fetch)
(uri (string-append "https://linux-libre.fsfla.org"
"/pub/linux-libre/releases/" version "-gnu/"
- "deblob-" version))
+ "deblob-" (version-major+minor version)))
(file-name (string-append "linux-libre-deblob-"
- (version-major+minor version)))
+ version))
(sha256 deblob-hash))
(origin
(method url-fetch)