summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-05-03 12:11:58 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-11-13 22:47:54 +0100
commitcfdbf2a5c43a6553dad4f7077de26cfa1c15d83b (patch)
tree8ae557bfdc0e374e1680080f7c12e7c1c892e637 /gnu
parent570f3b63709717a97a4a4501a6135e2c1f18bcdf (diff)
gnu: Add java-signpost-core.
* gnu/packages/web.scm (java-signpost-core): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1ea73bfa5b..7ce4889caf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -25,7 +25,7 @@
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017, 2019 Christopher Baines <mail@cbaines.net>
-;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018, 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
@@ -6529,6 +6529,36 @@ provides a very convenient API for extracting and manipulating data, using the
best of DOM, CSS, and jQuery-like methods.")
(license license:expat)))
+(define-public java-signpost-core
+ (package
+ (name "java-signpost-core")
+ (version "1.2.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mttkay/signpost")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l04yj2znch3hpyw90c4g4jan453w7d88l84bgl0c72i2kbb8z7h"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "signpost-core.jar"
+ #:source-dir "signpost-core/src/main/java"
+ #:test-dir "signpost-core/src/test"
+ ;; Tests all fail with InstantiationException from mockito
+ #:tests? #f))
+ (propagated-inputs
+ `(("java-commons-codec" ,java-commons-codec)))
+ (home-page "https://github.com/mttkay/signpost")
+ (synopsis "Lightweight client-side OAuth library for Java")
+ (description "Signpost is the easy and intuitive solution for signing
+HTTP messages on the Java platform in conformance with the OAuth Core 1.0a
+standard. Signpost follows a modular and flexible design, allowing you to
+combine it with different HTTP messaging layers.")
+ (license license:asl2.0)))
+
(define-public tidyp
(package
(name "tidyp")