summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-31 00:20:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-05-31 00:20:27 +0200
commitd818256e467af8fba9e80454ff29eccde3fae9ba (patch)
tree5b3728324ba5b00d7e4be4e45085b0e3a5f1ff50 /gnu
parent187d02cd437ae9e6d2a67e56c82502c6feea73cf (diff)
gnu: csound: Update to 6.14.0.
* gnu/packages/audio.scm (csound): Update to 6.14.0. [inputs]: move gettext-minimal... [native-inputs]: ... there. Also re-order inputs alphabetically.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 70746b8dfe..2d22dfc85a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -851,30 +851,30 @@ emulation (valve, tape), bit fiddling (decimator, pointer-cast), etc.")
(define-public csound
(package
(name "csound")
- (version "6.13.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/csound/csound.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "14822ybqyp31z18gky2y9zadr9dkbhabg97y139py73w7v3af1bh"))))
+ (version "6.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/csound/csound.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sr9knfhbm2m0wpkjq2l5n471vnl51wy4p6j4m95zqybimzb4s2j"))))
(build-system cmake-build-system)
- (inputs
- `(("alsa-lib" ,alsa-lib)
- ("boost" ,boost)
- ("pulseaudio" ,pulseaudio)
- ("libsndfile" ,libsndfile)
- ("liblo" ,liblo)
- ("ladspa" ,ladspa)
- ("jack" ,jack-1)
- ("gettext" ,gettext-minimal)))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
+ ("gettext" ,gettext-minimal)
("zlib" ,zlib)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("boost" ,boost)
+ ("jack" ,jack-1)
+ ("ladspa" ,ladspa)
+ ("liblo" ,liblo)
+ ("libsndfile" ,libsndfile)
+ ("pulseaudio" ,pulseaudio)))
(home-page "https://csound.com/")
(synopsis "Sound and music computing system")
(description