summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJames Smith <jsubuntuxp@disroot.org>2022-10-16 15:49:21 -0700
committerEfraim Flashner <efraim@flashner.co.il>2022-11-15 12:30:49 +0200
commitde61a0aa4a362795274750d5603909c294d5e036 (patch)
treef3fb67abeac6aac6a2f7e09e97165a3e21d12621 /gnu
parent3f58fbe34a3784bcab8426f878de5e639d88c4c4 (diff)
gnu: slade: Update to 3.2.1.
* gnu/packages/game-development.scm (slade): Update to 3.2.1. [arguments]: Use G-expressions. [phases]: Remove reset-slade.pk3-timestamp phase. [inputs]: Remove input labels. Add lua and mpg123. Replace wxwidgets-3.1 with wxwidgets. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm67
1 files changed, 30 insertions, 37 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 15bf93d51d..90205a89ab 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;; Copyright © 2021 Dmitry Polyakov <polyakov@liltechdude.xyz>
-;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2020-2022 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Andy Tai <atai@atai.org>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
@@ -516,52 +516,45 @@ support.")
(define-public slade
(package
(name "slade")
- (version "3.1.13")
+ (version "3.2.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/sirjuddington/SLADE")
(commit version)))
- (sha256 (base32 "009yc5m6y074wfalvwbrnv2zsmaf9yhbi8hzgs973di0zqnqv011"))
+ (sha256 (base32 "11ab38nv190lpvkdba5r2gckdrk4h15pri0zzslz7zy8qzg5fm18"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- '(#:configure-flags
- (list "-DWX_GTK3=ON" "-DNO_WEBVIEW=ON"
- (string-append "-DWITH_WXPATH="
- (assoc-ref %build-inputs "wxwidgets") "/bin")
- (string-append "-DwxWidgets_LIBRARIES="
- (assoc-ref %build-inputs "wxwidgets") "/lib"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'reset-slade.pk3-timestamps
- ;; This is neccessary to make slade reproducible due to
- ;; <https://bugs.gnu.org/44741>. TODO: Remove on next core update
- ;; cycle.
- (lambda _
- (invoke "find" "../source/dist/res" "-exec" "touch"
- "--no-dereference" "-t" "197001010000.00" "{}"
- "+")))
- (add-after 'install 'wrap-with-x11-gdk-backend
- ;; Set GDK_BACKEND to x11 to prevent crash on Wayland.
- ;; See https://github.com/sirjuddington/SLADE/issues/1097 for details.
- (lambda* (#:key outputs #:allow-other-keys)
- (wrap-program
- (string-append (assoc-ref outputs "out")
- "/bin/slade")
- '("GDK_BACKEND" = ("x11"))))))
- #:tests? #f)) ;; No test suite.
+ (list #:configure-flags
+ #~(list "-DWX_GTK3=ON" "-DNO_WEBVIEW=ON"
+ (string-append "-DWITH_WXPATH="
+ #$(this-package-input "wxwidgets") "/bin")
+ (string-append "-DwxWidgets_LIBRARIES="
+ #$(this-package-input "wxwidgets") "/lib"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-with-x11-gdk-backend
+ ;; Set GDK_BACKEND to x11 to prevent crash on Wayland.
+ ;; See https://github.com/sirjuddington/SLADE/issues/1097 for
+ ;; details.
+ (lambda _
+ (wrap-program (string-append #$output "/bin/slade")
+ '("GDK_BACKEND" = ("x11"))))))
+ #:tests? #f)) ;; No test suite.
(inputs
- `(("bash" ,bash-minimal)
- ("curl" ,curl)
- ("fluidsynth" ,fluidsynth)
- ("freeimage" ,freeimage)
- ("ftgl" ,ftgl)
- ("glew" ,glew)
- ("gtk+" ,gtk+)
- ("sfml" ,sfml)
- ("wxwidgets" ,wxwidgets-3.1)))
+ (list bash-minimal
+ curl
+ fluidsynth
+ freeimage
+ ftgl
+ glew
+ gtk+
+ lua
+ mpg123
+ sfml
+ wxwidgets))
(native-inputs
(list pkg-config which zip))
(home-page "https://slade.mancubus.net")