summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 16:43:52 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-01-03 16:46:40 +0100
commite0786d13e8b8280c4d82474829a72a58e45b452f (patch)
tree04bec60a13f14a2202cdae5b73905ce17ca9b007 /gnu
parentaa47c9e7d3874bf0851373a7e41560d9e500874a (diff)
gnu: Add parachute.
* gnu/packages/lisp-xyz.scm (cl-parachute, sbcl-parachute): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0a7b7582d8..7c04f1ac5b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -7340,3 +7340,35 @@ macro. This library provides a set of simple utilities to help with that.")
(define-public cl-form-fiddle
(sbcl-package->cl-source-package sbcl-form-fiddle))
+
+(define-public sbcl-parachute
+ (let ((commit "ca04dd8e43010a6dfffa26dbe1d62af86008d666")
+ (revision "0"))
+ (package
+ (name "sbcl-parachute")
+ (version (git-version "1.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/Shinmera/parachute")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mvsm3r0r6a2bg75nw0q7n9vlby3ch45qjl7hnb5k1z2n5x5lh60"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)
+ ("form-fiddle" ,sbcl-form-fiddle)))
+ (synopsis "Extensible and cross-compatible testing framework for Common Lisp")
+ (description
+ "Parachute is a simple-to-use and extensible testing framework.
+In Parachute, things are organised as a bunch of named tests within a package.
+Each test can contain a bunch of test forms that make up its body.")
+ (home-page "https://shinmera.github.io/parachute/")
+ (license license:zlib))))
+
+(define-public cl-parachute
+ (sbcl-package->cl-source-package sbcl-parachute))