summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-10-10 12:05:09 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-03 11:48:31 +0100
commite62ffc774efc103af42818cb8ac2350dddaf8cc2 (patch)
tree7d340238c872a038a05c9af40fa6026a5c06e43e /gnu
parentdb1ccf03b727c469d14f7552353c9e5fe4fa036e (diff)
gnu: emacs-modus-operandi-theme: Update to 0.13.0.
* gnu/packages/emacs-xyz.scm (emacs-modus-operandi-theme): Update to 0.13.0. [source]: Use GitHub instead of GNU ELPA, as ELPA is out of date. [arguments]: Add phase to remove "modus-vivendi-theme.el". Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9c606dea97..2043ce19df 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22877,15 +22877,24 @@ Emacs that integrate with major modes like Org-mode.")
(define-public emacs-modus-operandi-theme
(package
(name "emacs-modus-operandi-theme")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/"
- "modus-operandi-theme-" version ".el"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/modus-themes")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1mllyysn701qfnglxs7n2f6mrzrz55v9hcwspvafc6fl2blr393y"))))
+ (base32 "0i6n3pzrmlgabsijy6z0hhs71q7g99yagwr2m33lr30skqc9rvdn"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-other-theme
+ (lambda _
+ (delete-file "modus-vivendi-theme.el")
+ #t)))))
(home-page "https://gitlab.com/protesilaos/modus-themes")
(synopsis "Accessible light theme (WCAG AAA)")
(description