summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-10-10 01:03:18 -0500
committerMarius Bakke <marius@gnu.org>2020-10-13 23:36:44 +0200
commite8c5533d26b4441c96e9ae92350efcb24d787c4b (patch)
treec261699cb04be8c9e05930d055c77897f376e989 /gnu
parent23a97f52405b49309bf8825099d8c66a9ad9998d (diff)
gnu: Add python-dpath.
* gnu/packages/python-xyz.scm (python-dpath): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f5c58609f5..10fa9b54b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22067,6 +22067,42 @@ dates in almost any string formats commonly found on web pages.")
(description "This package provides a parser for Python dependency files.")
(license license:expat)))
+(define-public python-dpath
+ (package
+ (name "python-dpath")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dpath" version))
+ (sha256
+ (base32
+ "1ymi9ssk7i0mx3mviplf4csfvzibdd6wyj4qzj6s487n9xgnp85y"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-hypothesis" ,python-hypothesis)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ ;; This invokation is taken from tox.ini.
+ (invoke "nosetests" "-d" "-v" "tests/"))))))
+ (home-page "https://github.com/akesterson/dpath-python")
+ (synopsis "Filesystem-like pathing and searching for dictionaries")
+ (description
+ "@code{python-dpath} is a library for accessing and searching
+dictionaries via /slashed/paths ala xpath.
+
+Basically it lets you glob over a dictionary as if it were a filesystem. It
+allows you to specify globs (ala the bash eglob syntax, through some advanced
+fnmatch.fnmatch magic) to access dictionary elements, and provides some
+facility for filtering those results.")
+ (license license:expat)))
+
(define-public python-safety
(package
(name "python-safety")