summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-21 17:44:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-21 18:43:01 +0100
commitf45e314e19c903d2686d11184ecc689ffb444c0a (patch)
tree36f0b31dc2782701169c4502d323d9f9d040b4a9 /gnu
parent5308f15b433c4562dcbe1938b08d045a2adabe7f (diff)
gnu: zstd: Disable unrelated format support.
* gnu/packages/compression.scm (zstd)[arguments]: Add HAVE_LZMA=0 to
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 9ddc76fe81..5cdb14ba37 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1609,7 +1609,13 @@ or junctions, and always follows hard links.")
(delete 'configure)) ; no configure script
#:make-flags
(list "CC=gcc"
- (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ ;; Skip auto-detection of, and creating a dependency on, the build
+ ;; environment's ‘xz’ for what amounts to a dubious feature anyway.
+ "HAVE_LZMA=0"
+ ;; Not currently detected, but be explicit & avoid surprises later.
+ "HAVE_LZ4=0"
+ "HAVE_ZLIB=0")
#:test-target "test"))
(home-page "http://zstd.net/")
(synopsis "Zstandard real-time compression algorithm")