summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-14 15:38:10 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 19:01:16 -0800
commit7d387305077946c3a377f7247a7c32068ff55441 (patch)
tree28c1d8c2c3bf3cee915f28700abc6481d38376af /gnu
parent8dfceab779b10fcafb2bbb037f47d2faa4b40288 (diff)
gnu: Add python-kombu.
* gnu/packages/python.scm (python-kombu, python2-kombu): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ed3a252ce6..aee730b8d9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7935,3 +7935,41 @@ alternative when librabbitmq is not available.")
,@(package-arguments amqp)))
(native-inputs `(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs amqp))))))
+
+(define-public python-kombu
+ (package
+ (name "python-kombu")
+ (version "3.0.33")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "kombu" version))
+ (sha256
+ (base32
+ "16brjx2lgwbj2a37d0pjbfb84nvld6irghmqrs3qfncajp51hgc5"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-anyjson" ,python-anyjson)
+ ("python-amqp" ,python-amqp)))
+ (home-page "http://kombu.readthedocs.org")
+ (synopsis "Message passing library for Python")
+ (description "The aim of Kombu is to make messaging in Python as easy as
+possible by providing an idiomatic high-level interface for the AMQ protocol,
+and also provide proven and tested solutions to common messaging problems.
+AMQP is the Advanced Message Queuing Protocol, an open standard protocol for
+message orientation, queuing, routing, reliability and security, for which the
+RabbitMQ messaging server is the most popular implementation.")
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay python2-kombu))))))
+
+(define-public python2-kombu
+ (let ((kombu (package-with-python2
+ (strip-python2-variant python-kombu))))
+ (package
+ (inherit kombu)
+ (inputs `(("python2-setuptools" ,python2-setuptools)
+ ("python2-unittest2" ,python2-unittest2)
+ ,@(package-inputs kombu))))))