summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-02-08 13:31:27 +0800
committer宋文武 <iyzsong@gmail.com>2016-02-08 13:48:16 +0800
commit8b8775454b90acedda2d0aa669a6584ea306e7f3 (patch)
treece7a336c38d3da7fe67525a8e310f37909af81c2 /gnu
parent16095d27293dc80078dc55c3ba9a74cfaab17ce1 (diff)
gnu: Add nautilus.
* gnu/packages/gnome.scm (nautilus): New variable. Co-authored-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 63121d47b9..49e61973a0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
-;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
@@ -12,6 +12,7 @@
;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4607,3 +4608,43 @@ applications, for instance the Vinagre client, GNOME Boxes and virt-viewer.
GTK-VNC implements client side RFB protocol and authentication extensions such
as SASL, TLS and VeNCrypt. Additionally it supports encoding extensions.")
(license license:lgpl2.1+)))
+
+(define-public nautilus
+ (package
+ (name "nautilus")
+ (version "3.18.2") ; XXX: later version require gtk+-3.0 >= 3.18.5
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0jj23n8vmmyc4gp5xhiz7slsxwksydp26blxi5m154yaw9lgdp38"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ '(#:configure-flags '("--disable-tracker") ; XXX: not packaged
+ ;; XXX: FAIL: check-nautilus
+ ;; Settings schema 'org.gnome.nautilus.preferences' is not installed
+ #:tests? #f))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("gtk+" ,gtk+))) ; required by libnautilus-extension.pc
+ (inputs
+ ;; TODO: add gvfs support.
+ `(("dconf" ,dconf)
+ ("exempi" ,exempi)
+ ("gnome-desktop" ,gnome-desktop)
+ ("libexif" ,libexif)
+ ("libxml2" ,libxml2)))
+ (synopsis "File manager for GNOME")
+ (home-page "https://wiki.gnome.org/Apps/Nautilus")
+ (description
+ "Nautilus (Files) is a file manager designed to fit the GNOME desktop
+design and behaviour, giving the user a simple way to navigate and manage its
+files.")
+ (license license:gpl2+)))