summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:03:26 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 05:02:04 -0400
commit5dc9ded15df969265d2d29e850bb293f04d0c4fc (patch)
treeebe649c010e754b935ce9dbe05219f42258cf7a0 /gnu
parent20927c9331b493eaf94211ad9f8a5055e11b4588 (diff)
gnu: linux-libre-headers: Use invoke instead of system*.
* gnu/packages/linux.scm (linux-libre-headers)[arguments]: Use invoke and remove vestigial result code plumbing.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c3bd73023d..2f52df935d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -184,29 +184,29 @@ defconfig. Return the appropriate make target if applicable, otherwise return
(%current-system)))))
(setenv "ARCH" arch)
(format #t "`ARCH' set to `~a'~%" (getenv "ARCH"))
- (and (zero? (system* "make" defconfig))
- (zero? (system* "make" "mrproper" "headers_check"))))))
+ (invoke "make" defconfig)
+ (invoke "make" "mrproper" "headers_check"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (and (zero? (system* "make"
- (string-append "INSTALL_HDR_PATH=" out)
- "headers_install"))
- (begin
- (mkdir (string-append out "/include/config"))
- (call-with-output-file
- (string-append out
- "/include/config/kernel.release")
- (lambda (p)
- (format p "~a-default~%" ,version)))
-
- ;; Remove the '.install' and '..install.cmd' files; the
- ;; latter contains store paths, which pulls in bootstrap
- ;; binaries in the build environment, and prevents bit
- ;; reproducibility for the bootstrap binaries.
- (for-each delete-file (find-files out "\\.install"))
-
- #t))))))
+ (invoke "make"
+ (string-append "INSTALL_HDR_PATH=" out)
+ "headers_install")
+
+ (mkdir (string-append out "/include/config"))
+ (call-with-output-file
+ (string-append out
+ "/include/config/kernel.release")
+ (lambda (p)
+ (format p "~a-default~%" ,version)))
+
+ ;; Remove the '.install' and '..install.cmd' files; the
+ ;; latter contains store paths, which pulls in bootstrap
+ ;; binaries in the build environment, and prevents bit
+ ;; reproducibility for the bootstrap binaries.
+ (for-each delete-file (find-files out "\\.install"))
+
+ #t))))
#:allowed-references ()
#:tests? #f))
(home-page "https://www.gnu.org/software/linux-libre/")