summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-19 16:10:25 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-20 13:30:24 +0200
commit5b5ea159acbd90d3a87ad5a5be33d97cf2293425 (patch)
tree1d5c90a5a44b682f7113c30170c437c83fa8a9ba /gnu
parent4627ea587750886f5de5ac42cc69c89e260ef690 (diff)
gnu: openblas: Disable DYNAMIC_ARCH on MIPS.
* gnu/packages/maths.scm (openblas)[arguments]: Do not pass DYNAMIC_ARCH when building for MIPS. Also make non-substitutable for MIPS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f27903cc1a..519ef68794 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1037,7 +1037,11 @@ constant parts of it.")
"0av3pd96j8rx5i65f652xv9wqfkaqn0w4ma1gvbyz73i6j2hi9db"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ;no "check" target
+ `(#:tests? #f ;no "check" target
+ ;; DYNAMIC_ARCH is not supported on MIPS. When it is disabled,
+ ;; OpenBLAS will tune itself to the build host, so we need to disable
+ ;; substitutions.
+ #:substitutable? ,(not (string-prefix? "mips" (%current-system)))
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"
@@ -1045,7 +1049,10 @@ constant parts of it.")
;; Build the library for all supported CPUs. This allows
;; switching CPU targets at runtime with the environment variable
;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.
- "DYNAMIC_ARCH=1")
+ ;; Unfortunately, this is not supported on MIPS.
+ ,@(if (string-prefix? "mips" (%current-system))
+ '()
+ '("DYNAMIC_ARCH=1")))
;; no configure script
#:phases (alist-delete 'configure %standard-phases)))
(inputs