summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-08 23:28:32 +0530
committerMarius Bakke <mbakke@fastmail.com>2017-03-09 16:53:23 +0100
commit77e9941160e40bdf6f1260f360121bccb58be313 (patch)
tree88bc7c4a67cf276fb6b7fc8cb856125075ba54e6 /gnu
parent33e9490ca1edb05c3a3e2d5bd0402ace5ac30ad9 (diff)
gnu: Add python2-ttystatus.
* gnu/packages/python.scm (python2-ttystatus): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index abc7f448cf..7783cf9ab1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13516,3 +13516,28 @@ need to do, such as parsing the command line for options, and
iterating over input files.")
(license license:gpl2+)))
+(define-public python2-ttystatus
+ (package
+ (name "python2-ttystatus")
+ (version "0.32")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://git.liw.fi/cgi-bin/cgit/cgit.cgi/ttystatus/snapshot/ttystatus-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0b5g889jj23r2w1hi300cdldx6jvspanp0ybf5n1qvdvl150aamf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (home-page "https://liw.fi/ttystatus/")
+ (synopsis "Python library for showing progress reporting and
+status updates on terminals")
+ (description "@code{python2-ttystatus} is a python library for
+showing progress reporting and status updates on terminals, for
+command line programs. Output is automatically adapted to the width
+of the terminal: truncated if it does not fit, and resized if the
+terminal size changes.")
+ (license license:gpl3+)))