summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:23:07 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commitb668a95cf3104bedcb629f107b1c75e31ccfae91 (patch)
treea8ed7a335b89ed60cca787ea54e72c0659e083a9 /gnu
parent0661b4db2e25f2e34de60335cb8398fcee3a09dd (diff)
gnu: Add r-memoise.
* gnu/packages/statistics.scm (r-memoise): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index a3710e0d9b..1a99a09b48 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -769,3 +769,23 @@ the execution time of R expressions.")
"This package provides useful tools to pry back the covers of R and
understand the language at a deeper level.")
(license license:gpl2)))
+
+(define-public r-memoise
+ (package
+ (name "r-memoise")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "memoise" version))
+ (sha256
+ (base32
+ "19wm4b3kq6xva43kga3xydnl7ybl5mq7b4y2fczgzzjz63jd75y4"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)))
+ (home-page "http://github.com/hadley/memoise")
+ (synopsis "Memoise functions for R")
+ (description
+ "This R package allows to cache the results of a function so that when
+you call it again with the same arguments it returns the pre-computed value.")
+ (license license:expat)))