summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBoskovits, Gábor <boskovits@gmail.com>2017-02-07 00:13:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-07 17:56:06 +0100
commit189d8422573bdcb9392dad76426ab3e9518017ec (patch)
tree50a7d1e078f604e6070fd7449920b9019aa0057b /gnu
parentd480ed7edb7ad787829fd8220c86220ca34ce8ac (diff)
gnu: Add lshw.
* gnu/packages/linux.scm (lshw): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 08d8c50fd4..5f0db58009 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2016 ng0 <ng0@libertad.pw>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
+;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3407,3 +3408,32 @@ set the screen to be pitch black at a vaĺue of 0 (or higher).
Light is the successor of lightscript.")
(license license:gpl3+)))
+
+(define-public lshw
+ (package
+ (name "lshw")
+ (version "B.02.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ezix.org/software/"
+ "files/lshw-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0brwra4jld0d53d7jsgca415ljglmmx1l2iazpj4ndilr48yy8mf"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases (delete 'configure))
+ #:tests? #f ; no tests
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ (synopsis "List hardware information")
+ (description
+ "@command{lshw} (Hardware Lister) is a small tool to provide
+detailed information on the hardware configuration of the machine.
+It can report exact memory configuration, firmware version, mainboard
+configuration, CPU version and speed, cache configuration, bus speed,
+and more on DMI-capable x86 or EFI (IA-64) systems and on some PowerPC
+machines (PowerMac G4 is known to work).")
+ (home-page "https://www.ezix.org/project/wiki/HardwareLiSter")
+ (license license:gpl2+)))