summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ngillmann@runbox.com>2017-02-03 16:56:25 +0000
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-02-04 14:45:31 +0100
commit1a0a5509dd169cc87c611c6c5fe38c787d1afe89 (patch)
treed0e73b0985e924c14c5ddc17801d50385cd5b4cd /gnu
parent1ae60db842b13fb3057d78058757e649657f8980 (diff)
gnu: Add python-lzo.
* gnu/packages/compression.scm (python-lzo): New variable. Co-authored-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 09dac4d7b0..9897883184 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -365,6 +365,44 @@ LZO is written in ANSI C. Both the source code and the compressed data
format are designed to be portable across platforms.")
(license license:gpl2+)))
+(define-public python-lzo
+ (package
+ (name "python-lzo")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-lzo" version))
+ (sha256
+ (base32
+ "11p3ifg14p086byhhin6azx5svlkg8dzw2b5abixik97xd6fm81q"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:test-target "check"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setuppy
+ (lambda _
+ (substitute* "setup.py"
+ (("include_dirs.append\\(.*\\)")
+ (string-append "include_dirs.append('"
+ (assoc-ref %build-inputs "lzo")
+ "/include/lzo"
+ "')")))
+ #t)))))
+ (inputs
+ `(("lzo" ,lzo)))
+ (home-page "https://github.com/jd-boyd/python-lzo")
+ (synopsis "Python bindings for the LZO data compression library")
+ (description
+ "Python-LZO provides Python bindings for LZO, i.e. you can access
+the LZO library from your Python scripts thereby compressing ordinary
+Python strings.")
+ (license license:gpl2+)))
+
+(define-public python2-lzo
+ (package-with-python2 python-lzo))
+
(define-public lzop
(package
(name "lzop")