summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-05 17:44:30 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-16 20:08:37 +0100
commit3f623d00a7c30f99de338fa0ba0969ae5dd627b5 (patch)
tree563130f88103e89abecaaa14633c2bf6b68038ab /gnu
parentb5bab81c10ce0ea4b10e14270b3493b8d1e70675 (diff)
gnu: Add ocaml-ppx-derivers.
* gnu/packages/ocaml.scm (ocaml-ppx-derivers): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c3b0459e0a..e1ab867254 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5053,3 +5053,29 @@ is now @code{Ocaml_common.Ast_helper}.")
re-exports the input/output functions of the OCaml standard libraries using
a more consistent API.")
(license license:expat)))
+
+(define-public ocaml-ppx-derivers
+ (package
+ (name "ocaml-ppx-derivers")
+ (version "1.2")
+ (home-page
+ "https://github.com/ocaml-ppx/ppx_derivers")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bnhihl1w31as5w2czly1v3d6pbir9inmgsjg2cj6aaj9v1dzd85"))))
+ (build-system dune-build-system)
+ (arguments
+ '(#:tests? #f)) ;no tests
+ (synopsis "Shared @code{@@deriving} plugin registry")
+ (description
+ "Ppx_derivers is a tiny package whose sole purpose is to allow
+ppx_deriving and ppx_type_conv to inter-operate gracefully when linked
+as part of the same ocaml-migrate-parsetree driver.")
+ (license license:bsd-3)))