summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-18 18:01:50 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-18 18:01:50 +0100
commit7be4a4b0ae68de0974e0ac6a4e313f1001bcd73d (patch)
treec68c0f24252b593b2a244be12f7adfd25fd187c0 /gnu
parentb567abcf1afb13b4f12e25df436db99a72e56443 (diff)
gnu: weechat: Fix patching of assignments to 'python2_bin'.
Fixes a regression introduced in a9346fa. * gnu/packages/weechat.scm (weechat)[arguments]: Make sure PYTHON2_BIN can be freed with 'free'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/weechat.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/weechat.scm b/gnu/packages/weechat.scm
index 48250302c3..27349ec60d 100644
--- a/gnu/packages/weechat.scm
+++ b/gnu/packages/weechat.scm
@@ -87,10 +87,10 @@
(add-before 'build 'set-python-file-name
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/plugins/python/weechat-python.c"
- (("python2_bin = .*;")
- (string-append "python2_bin = \""
+ (("python2_bin = weechat_python_get_python2_bin.*;")
+ (string-append "python2_bin = strdup (\""
(assoc-ref inputs "python")
- "/bin/python\";\n")))
+ "/bin/python\");\n")))
#t)))))
(synopsis "Extensible chat client")
(description "WeeChat (Wee Enhanced Environment for Chat) is an