summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-03 10:40:45 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-16 20:08:35 +0100
commitb5bab81c10ce0ea4b10e14270b3493b8d1e70675 (patch)
treed4cec2678cc7b7c85b1efbac7d5dd1c62609a880 /gnu
parentac06a773f5c93cf2b59d15150a1a912bd0320479 (diff)
gnu: Add ocaml-migrate-parsetree.
* gnu/packages/ocaml.scm (ocaml-migrate-parsetree): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4cda0ccd2a..c3b0459e0a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5026,3 +5026,30 @@ provided by companion libraries such as
so they don't expose everything at toplevel. For instance, @code{Ast_helper}
is now @code{Ocaml_common.Ast_helper}.")
(license license:expat)))
+
+(define-public ocaml-stdio
+ (package
+ (name "ocaml-stdio")
+ (version "0.11.0")
+ (home-page "https://github.com/janestreet/stdio")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1facajqhvq34g2wrg368y0ajxd6lrj5b3lyzyj0jhdmraxajjcwn"))))
+ (build-system dune-build-system)
+ (inputs `(("ocaml-base" ,ocaml-base)
+ ("ocaml-sexplib0" ,ocaml-sexplib0)))
+ (arguments
+ '(#:tests? #f)) ;no tests
+ (synopsis "Standard IO library for OCaml")
+ (description
+ "Stdio implements simple input/output functionalities for OCaml. It
+re-exports the input/output functions of the OCaml standard libraries using
+a more consistent API.")
+ (license license:expat)))