summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-02-06 18:44:51 +0100
committerLudovic Courtès <ludo@gnu.org>2017-02-08 16:17:05 +0100
commitcce0da5e8d97528f5c556237b5085aa38dc151b6 (patch)
tree139ba5dc350c988da97332418b3989482b6a93ff /gnu
parent2149d3e3e58894795b582f2d113a879b00540722 (diff)
gnu: Add vinagre.
* gnu/packages/gnome.scm (vinagre): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cd115f1f0c..0c41618d27 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -96,11 +97,13 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages rdesktop)
#:use-module (gnu packages scanner)
#:use-module (gnu packages ssh)
#:use-module (gnu packages xml)
#:use-module (gnu packages gl)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages spice)
#:use-module (gnu packages tex)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
@@ -1900,6 +1903,43 @@ selection and URL hints.")))
`(("gtk+" ,gtk+-2) ; required by libvte.pc
("ncurses" ,ncurses))))) ; required by libvte.la
+(define-public vinagre
+ (package
+ (name "vinagre")
+ (version "3.22.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "10jya3jyrm18nbw3v410gbkc7677bqamax44pzgd3j15randn76d"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("glib-bin" ,glib "bin") ;for glib-compile-schemas
+ ("gtk+-bin" ,gtk+ "bin"))) ;for gtk-update-icon-cache
+ (inputs
+ `(("libxml2" ,libxml2)
+ ("gtk-vnc" ,gtk-vnc)
+ ("gnome-keyring" ,gnome-keyring)
+ ("libsecret" ,libsecret)
+ ("freerdp" ,freerdp)
+ ("spice" ,spice)
+ ("spice-gtk" ,spice-gtk)
+ ("telepathy-glib" ,telepathy-glib)
+ ("vte" ,vte)))
+ (arguments
+ `(#:configure-flags '("--enable-rdp")))
+ (home-page "https://wiki.gnome.org/Apps/Vinagre")
+ (synopsis "Remote desktop viewer for GNOME")
+ (description "Vinagre is a remote display client supporting the VNC, SPICE
+and RDP protocols.")
+ (license license:gpl3+)))
+
(define-public dconf
(package
(name "dconf")