summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorErik Edrosa <erik.edrosa@gmail.com>2015-11-15 20:29:46 -0500
committerLudovic Courtès <ludo@gnu.org>2015-11-18 12:21:45 +0100
commitf7d17ac7565b6b1d005ff735180e5b24c9bf32cc (patch)
tree5abb97625145071fdc109cede2f4d50e9c8eb512 /gnu
parent49846012f098be181ca84d66233edb07fbc77d67 (diff)
gnu: Add python-pystache.
* gnu/packages/python.scm (python-pystache, python2-pystache): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4e54ef94f5..508479b250 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
+;;; Copyright © 2015 Erik Edrosa <erik.edrosa@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2352,6 +2353,29 @@ written in pure Python.")
(define-public python2-jinja2
(package-with-python2 python-jinja2))
+(define-public python-pystache
+ (package
+ (name "python-pystache")
+ (version "0.5.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pystache" version))
+ (sha256
+ (base32
+ "0nmqsfmiw4arjxqkmf9z66ml950pcdjk6aq4gin4sywmzdjw5fzp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://defunkt.io/pystache/")
+ (synopsis "Python logic-less template engine")
+ (description
+ "Pystache is a Python implementation of the framework agnostic,
+logic-free templating system Mustache.")
+ (license license:expat)))
+
+(define-public python2-pystache
+ (package-with-python2 python-pystache))
+
(define-public python-joblib
(package
(name "python-joblib")