summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 17:50:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 18:07:06 +0100
commitd0d207cdca1abb97db95260c804f5b8ba963f098 (patch)
tree3a87d6087aa4c6458af5c2e2a7e96f5ded483890 /gnu
parentabd402e3a1f3856243d2956f073901fc1a4485a0 (diff)
gnu: tomsfastmath: Update to 0.13.1.
* gnu/packages/multiprecision.scm (tomsfastmath): Update to 0.13.1. [source]: Remove patch. * gnu/packages/patches/tomsfastmath-constness.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/multiprecision.scm11
-rw-r--r--gnu/packages/patches/tomsfastmath-constness.patch76
3 files changed, 5 insertions, 83 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ce43db3c1d..d1ccf4078a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1274,7 +1274,6 @@ dist_patch_DATA = \
%D%/packages/patches/tk-find-library.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \
%D%/packages/patches/ttfautohint-source-date-epoch.patch \
- %D%/packages/patches/tomsfastmath-constness.patch \
%D%/packages/patches/totem-meson-easy-codec.patch \
%D%/packages/patches/tuxpaint-stamps-path.patch \
%D%/packages/patches/twinkle-include-qregexpvalidator.patch \
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 969f0659a8..7ae3886166 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -230,17 +230,16 @@ and numerical quadrature programs are included.")
(define-public tomsfastmath
(package
(name "tomsfastmath")
- (version "0.13.0")
+ (version "0.13.1")
(synopsis "Large integer arithmetic library")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libtom/tomsfastmath/"
"releases/download/v" version "/"
- "tfm-" (version-major+minor version) ".tar.bz2"))
+ "tfm-" version ".tar.xz"))
(sha256
(base32
- "01rlsvp6lskk2a0gfdi24ak5h8vdwi6kqbvbwjnmb92r0zrfdvwd"))
- (patches (search-patches "tomsfastmath-constness.patch"))))
+ "0f0pmiaskh89sp0q933pafxb914shpaj5ad8sb5rzk1wv8d7mja7"))))
(build-system gnu-build-system)
(native-inputs
`(("libtool" ,libtool)))
@@ -252,7 +251,7 @@ and numerical quadrature programs are included.")
"CC=gcc")
#:phases
(modify-phases %standard-phases
- (delete 'configure) ;no configuration
+ (delete 'configure) ; no configuration
(replace 'check
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make"
@@ -262,7 +261,7 @@ and numerical quadrature programs are included.")
(invoke "./test")))
(add-before 'install 'install-nogroup
(lambda _
- ;; Let permissions inherit from the current process
+ ;; Let permissions inherit from the current process.
(substitute* "makefile.shared"
(("-g \\$\\(GROUP\\) -o \\$\\(USER\\)") ""))
#t))
diff --git a/gnu/packages/patches/tomsfastmath-constness.patch b/gnu/packages/patches/tomsfastmath-constness.patch
deleted file mode 100644
index 7c6ab5bbec..0000000000
--- a/gnu/packages/patches/tomsfastmath-constness.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From dac089515901d6bf315cd15a6e744b8d2c02c1cb Mon Sep 17 00:00:00 2001
-From: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
-Date: Sat, 31 Oct 2015 22:48:07 +0100
-Subject: [PATCH] tfm: make a few functions static
-
-clamav expects them to be static and it does not seem bad to do so.
-
-Signed-off-by: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
----
- src/bin/fp_read_radix.c | 2 +-
- src/bin/fp_read_signed_bin.c | 2 +-
- src/bin/fp_read_unsigned_bin.c | 2 +-
- src/headers/tfm.h | 6 +++---
- 4 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/src/bin/fp_read_radix.c b/src/bin/fp_read_radix.c
-index 0b5e826..431afa0 100644
---- a/src/bin/fp_read_radix.c
-+++ b/src/bin/fp_read_radix.c
-@@ -9,7 +9,7 @@
- */
- #include <tfm_private.h>
-
--int fp_read_radix(fp_int *a, char *str, int radix)
-+int fp_read_radix(fp_int *a, const char *str, int radix)
- {
- int y, neg;
- char ch;
-diff --git a/src/bin/fp_read_signed_bin.c b/src/bin/fp_read_signed_bin.c
-index e2b8003..6467d19 100644
---- a/src/bin/fp_read_signed_bin.c
-+++ b/src/bin/fp_read_signed_bin.c
-@@ -9,7 +9,7 @@
- */
- #include <tfm_private.h>
-
--void fp_read_signed_bin(fp_int *a, unsigned char *b, int c)
-+void fp_read_signed_bin(fp_int *a, const unsigned char *b, int c)
- {
- /* read magnitude */
- fp_read_unsigned_bin (a, b + 1, c - 1);
-diff --git a/src/bin/fp_read_unsigned_bin.c b/src/bin/fp_read_unsigned_bin.c
-index 3ee64c0..2ee89cb 100644
---- a/src/bin/fp_read_unsigned_bin.c
-+++ b/src/bin/fp_read_unsigned_bin.c
-@@ -9,7 +9,7 @@
- */
- #include <tfm_private.h>
-
--void fp_read_unsigned_bin(fp_int *a, unsigned char *b, int c)
-+void fp_read_unsigned_bin(fp_int *a, const unsigned char *b, int c)
- {
- /* zero the int */
- fp_zero (a);
-diff --git a/src/headers/tfm.h b/src/headers/tfm.h
-index af87b56..f406388 100644
---- a/src/headers/tfm.h
-+++ b/src/headers/tfm.h
-@@ -467,14 +467,14 @@ int fp_prime_random_ex(fp_int *a, int t, int size, int flags, tfm_prime_callback
- int fp_count_bits(fp_int *a);
-
- int fp_unsigned_bin_size(fp_int *a);
--void fp_read_unsigned_bin(fp_int *a, unsigned char *b, int c);
-+void fp_read_unsigned_bin(fp_int *a, const unsigned char *b, int c);
- void fp_to_unsigned_bin(fp_int *a, unsigned char *b);
-
- int fp_signed_bin_size(fp_int *a);
--void fp_read_signed_bin(fp_int *a, unsigned char *b, int c);
-+void fp_read_signed_bin(fp_int *a, const unsigned char *b, int c);
- void fp_to_signed_bin(fp_int *a, unsigned char *b);
-
--int fp_read_radix(fp_int *a, char *str, int radix);
-+int fp_read_radix(fp_int *a, const char *str, int radix);
-
- int fp_radix_size(fp_int *a, int radix, int *size);
- int fp_toradix(fp_int *a, char *str, int radix);