summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-08-03 21:01:40 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-03 21:08:39 +1000
commit124df723a0150e968910e34d5e94023b18901d0c (patch)
treed43f8c1d659c1b0285024ad4fbb2233f0e2532b0 /gnu
parent12b63ab505f781e49b6e7dda2d9eca0aaf24eaf1 (diff)
gnu: python-bz2file: Disable tests.
* gnu/packages/python.scm (python-bz2file)[arguments]: Disable tests. (python2-bz2file)[arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0557ab5f09..41b9bd7986 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8836,12 +8836,7 @@ LDFLAGS and parse the output to build extensions with setup.py.")
"126s53fkpx04f33a829yqqk8fj4png3qwg4m66cvlmhmwc8zihb4"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; python setup.py test does not work as of 0.98
- ;; but there is only the one test file
- (replace 'check
- (lambda _ (zero? (system* "python" "test_bz2file.py")))))))
+ `(#:tests? #f)) ; Tests use deprecated python modules.
(home-page "https://github.com/nvawda/bz2file")
(synopsis "Read and write bzip2-compressed files")
(description
@@ -8858,7 +8853,15 @@ development version of CPython that are not available in older releases.")
(package
(inherit base)
(native-inputs
- `(("python2-setuptools" ,python2-setuptools))))))
+ `(("python2-setuptools" ,python2-setuptools)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; 'python setup.py test' does not work as of 0.98.
+ ;; There is only the one test file, so we run it directly.
+ (replace 'check
+ (lambda _ (zero? (system* "python"
+ "test_bz2file.py"))))))))))
(define-public python-cysignals
(package