summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-09-13 12:30:40 +0200
committerLeo Famulari <leo@famulari.name>2016-09-13 12:41:44 -0400
commit243db8245e6d8ee6aae80ce4606fb58cb8b23443 (patch)
tree0f89174f268b9fa5270583ea17a12dd352d31a7c /gnu
parentd15e2ef05a8fe711d5fda75c198c5299961d4716 (diff)
gnu: Add python-lit, python2-lit.
* gnu/packages/python.scm (python-lit, python2-lit): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e918149b41..e2e1ec2ee8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10324,3 +10324,31 @@ Python to manipulate OpenDocument 1.2 files.")
(native-inputs
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+
+(define-public python-lit
+ (package
+ (name "python-lit")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "lit" version))
+ (sha256
+ (base32
+ "135m2b9cwih85g66rjggavck328z7lj37srgpq3jxszbg0g2b91y"))))
+ (build-system python-build-system)
+ (home-page "http://llvm.org/")
+ (synopsis "LLVM Software Testing Tool")
+ (description "@code{lit} is a portable tool for executing LLVM and Clang
+style test suites, summarizing their results, and providing indication of
+failures.")
+ (license license:ncsa)
+ (properties `((python2-variant . ,(delay python2-lit))))))
+
+(define-public python2-lit
+ (let ((base (package-with-python2 (strip-python2-variant python-lit))))
+ (package
+ (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))