summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-29 06:09:39 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit28cecbb7ccbb87593d5f81b4ab0a7d32477b10f4 (patch)
treefd51371cdfe8a8fb00fc581f308d4e1cef48eb2b /gnu
parentd7e729fe08284b15aee074eb61c964953c04d0a2 (diff)
gnu: Add python-wsgi-intercept.
* gnu/packages/python.scm (python-wsgi-intercept): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d45db218e1..9bc8b8dfef 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6880,3 +6880,30 @@ the last py.test invocation.")
framework which enables you to test server connections locally.")
(home-page "https://pypi.python.org/pypi/pytest-localserver")
(license license:expat)))
+
+(define-public python-wsgi-intercept
+ (package
+ (name "python-wsgi-intercept")
+ (version "0.10.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "wsgi_intercept" version))
+ (sha256
+ (base32
+ "0xyfchacywb1mql84270mcidsqc5ssyspd18yacjk82x2xc68h0r"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-httplib2" ,python-httplib2)
+ ("python-requests" ,python-requests)))
+ (synopsis "Puts a WSGI application in place of a real URI for testing")
+ (description "Wsgi_intercept installs a WSGI application in place of a real
+URI for testing. Testing a WSGI application normally involves starting a
+server at a local host and port, then pointing your test code to that address.
+Instead, this library lets you intercept calls to any specific host/port
+combination and redirect them into a WSGI application importable by your test
+program. Thus, you can avoid spawning multiple processes or threads to test
+your Web app.")
+ (home-page "https://github.com/cdent/wsgi-intercept")
+ (license license:expat)))