summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 22:10:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:42 +0100
commit44c31aaae8b7ba021c0144dead0ccb4fee929d10 (patch)
tree76db1b68160b643e6958cfc36ffa6e96c0803075 /gnu
parent0ef5191c8800fbcaef71ecea53708ba57c6efe7b (diff)
gnu: Add perl-text-csv-xs.
* gnu/packages/perl.scm (perl-text-csv-xs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 427705b132..42514d1a1e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6768,6 +6768,29 @@ decomposition of comma-separated values. An instance of the Text::CSV class
can combine fields into a CSV string and parse a CSV string into fields.")
(license (package-license perl))))
+(define-public perl-text-csv-xs
+ (package
+ (name "perl-text-csv-xs")
+ (version "1.25")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/H/HM/HMBRAND/"
+ "Text-CSV_XS-" version ".tgz"))
+ (sha256
+ (base32
+ "06zlfbqrwbl0g2g3bhk6046yy5pf2rz80fzcp8aj47rnswz2yx5k"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Text-CSV_XS")
+ (synopsis "Rountines for manipulating CSV files")
+ (description "@code{Text::CSV_XS} provides facilities for the composition
+and decomposition of comma-separated values. An instance of the
+@code{Text::CSV_XS} class will combine fields into a CSV string and parse a
+CSV string into fields. The module accepts either strings or files as input
+and support the use of user-specified characters for delimiters, separators,
+and escapes.")
+ (license (package-license perl))))
+
(define-public perl-text-diff
(package
(name "perl-text-diff")