summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-09 19:11:46 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit5c299bf016b822997c012db988e73fcaef113321 (patch)
tree6c9663fcb3c6d4a2bfcecc1d1db1cd0ee10ca15e /gnu
parenta2f6a3d502768e58b12a64943994dd2102b6ff91 (diff)
gnu: Add python-icalendar.
* gnu/packages/python.scm (python-icalendar): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7b400d11cc..0eb3c85a80 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6928,3 +6928,23 @@ your Web app.")
processes across test runs.")
(home-page "https://bitbucket.org/pytest-dev/pytest-xprocess")
(license license:expat)))
+
+(define-public python-icalendar
+ (package
+ (name "python-icalendar")
+ (version "3.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "icalendar" version))
+ (sha256
+ (base32
+ "0fhrczdj3jxy5bvswphp3vys7vwv5c9bpwg7asykqwa3z6253q6q"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil-2" ,python-dateutil-2)
+ ("python-pytz" ,python-pytz)))
+ (synopsis "Python library for parsing iCalendar files")
+ (description "The icalendar package is a parser/generator of iCalendar
+files for use with Python.")
+ (home-page "https://github.com/collective/icalendar")
+ (license bsd-2)))