summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-29 06:04:15 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit7b3a4ee4c38d4932a560fb4621667ef8b745cad1 (patch)
tree7b3873e520c6de81208e8a52d913e0bcef4a15ab /gnu
parent7b17cab9020c716b4cb6a2bf9f6e001722c704c1 (diff)
gnu: Add python-apipkg.
* gnu/packages/python.scm (python-apipkg): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dfd554096e..f848395d06 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6780,3 +6780,25 @@ applications.")
applications.")
(home-page "https://github.com/click-contrib/click-log")
(license license:expat)))
+
+(define-public python-apipkg
+ (package
+ (name "python-apipkg")
+ (version "1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "apipkg" version))
+ (sha256
+ (base32
+ "1iks5701qnp3dlr3q1d9qm68y2plp2m029irhpz92a44psfkjf1f"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)))
+ (synopsis "Namespace control and lazy-import mechanism")
+ (description "With apipkg you can control the exported namespace of a Python
+package and greatly reduce the number of imports for your users. It is a small
+pure Python module that works on virtually all Python versions.")
+ (home-page "https://bitbucket.org/hpk42/apipkg")
+ (license license:expat)))