summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-12-29 05:59:46 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commit848964fe11e26f7d05301b0d496099e960834c5d (patch)
tree85d73873e1ee0f401eebbf41e04ed33d9db0369f /gnu
parent7b3a4ee4c38d4932a560fb4621667ef8b745cad1 (diff)
gnu: Add python-execnet.
* gnu/packages/python.scm (python-execnet): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f848395d06..6f83e3df20 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6802,3 +6802,31 @@ package and greatly reduce the number of imports for your users. It is a small
pure Python module that works on virtually all Python versions.")
(home-page "https://bitbucket.org/hpk42/apipkg")
(license license:expat)))
+
+(define-public python-execnet
+ (package
+ (name "python-execnet")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "execnet" version))
+ (sha256
+ (base32
+ "1rpk1vyclhg911p3hql0m0nrpq7q7mysxnaaw6vs29cpa6kx8vgn"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-apipkg" ,python-apipkg)))
+ (synopsis "Rapid multi-Python deployment")
+ (description "Execnet provides a share-nothing model with
+channel-send/receive communication for distributing execution across many
+Python interpreters across version, platform and network barriers. It has a
+minimal and fast API targetting the following uses:
+@enumerate
+@item distribute tasks to (many) local or remote CPUs
+@item write and deploy hybrid multi-process applications
+@item write scripts to administer multiple environments
+@end enumerate")
+ (home-page "http://codespeak.net/execnet/")
+ (license license:expat)))