summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-12-15 12:09:19 +0800
committer宋文武 <iyzsong@gmail.com>2015-12-18 10:30:17 +0800
commit960ae0cde4d05c33547b16fe97f17f82a9c562e1 (patch)
treee72db937fde7c9682dc7242a6764293dfbe3188b /gnu
parentc2fb20761a000b9be743ffe378b38409d5a4a556 (diff)
gnu: talloc: Use 'modify-phases' syntax.
* gnu/packages/samba.scm (talloc)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/samba.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 484eafb647..0873a00267 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -179,16 +179,16 @@ Desktops into Active Directory environments using the winbind daemon.")
"13c365f7y8idjf2v1jxdjpkc3lxdmsxxfxjx1ymianm7zjiph393"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; talloc uses a custom configuration script that runs a
- ;; python script called 'waf'.
- (setenv "CONFIG_SHELL" (which "sh"))
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))
- %standard-phases)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; talloc uses a custom configuration script that runs a
+ ;; python script called 'waf'.
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)))))))))
(inputs
`(("python" ,python-2)))
(home-page "http://talloc.samba.org")