summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 10:48:21 +0100
committerDavid Craven <david@craven.ch>2017-01-04 16:05:06 +0100
commitbc2c3bc627874eb201c15ea7356af27eecb2ae1c (patch)
tree25d5f7fabcbc1882c0862f2fc4d0346d0188eb54 /gnu
parent7a76b4afd0ce296bb462be8cf66234e41672c285 (diff)
gnu: Add camlzip.
* gnu/packages/ocaml.scm (camlzip): New variable. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f976544f0b..01587bbe7c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -780,3 +780,36 @@ compilers that can directly deal with packages.")
(description "Unit testing framework for OCaml. It is similar to JUnit and
other XUnit testing frameworks.")
(license license:expat)))
+
+(define-public camlzip
+ (package
+ (name "camlzip")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (ocaml-forge-uri name version 1616))
+ (sha256
+ (base32
+ "0m6gyjw46w3qnhxfsyqyag42znl5lwargks7w7rfchr9jzwpff68"))))
+ (build-system ocaml-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'fix-install-name
+ (lambda* (#:key #:allow-other-keys)
+ (substitute* "Makefile"
+ (("install zip") "install camlzip")))))
+ #:install-target "install-findlib"
+ #:make-flags
+ (list "all" "allopt"
+ (string-append "INSTALLDIR=" (assoc-ref %outputs "out")
+ "/lib/ocaml"))))
+ (home-page "http://forge.ocamlcore.org/projects/camlzip")
+ (synopsis "Provides easy access to compressed files")
+ (description "Provides easy access to compressed files in ZIP, GZIP and
+JAR format. It provides functions for reading from and writing to compressed
+files in these formats.")
+ (license license:lgpl2.1+)))