summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-04 15:12:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-06 14:18:25 +0200
commitbfdfb0f63fc200bbeb8587f2d63fe640172baf9b (patch)
tree75390096013fc979a0fd6dc7541aa6786f4c11c9 /gnu
parente9ef2c51d53ebbfdceff55587bf60f7763571df0 (diff)
gnu: Add ghc-xml-conduit.
* gnu/packages/haskell.scm (ghc-xml-conduit): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bdd8141f6a..e645ad3a12 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6427,6 +6427,40 @@ dependencies. The basic idea is that this package should only depend on
documents.")
(license license:expat)))
+(define-public ghc-xml-conduit
+ (package
+ (name "ghc-xml-conduit")
+ (version "1.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/xml-conduit/"
+ "xml-conduit-" version ".tar.gz"))
+ (sha256
+ (base32
+ "10yw8jiksw21jgwqjjd1ixflavcblisgkp9qq3ba05vadc35lqr5"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-text" ,ghc-text)
+ ("ghc-xml-types" ,ghc-xml-types)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "http://github.com/snoyberg/xml")
+ (synopsis "Utilities for dealing with XML with the conduit package")
+ (description
+ "This package provides pure-Haskell utilities for dealing with XML with
+the @code{conduit} package.")
+ (license license:expat)))
+
(define-public ghc-union-find
(package
(name "ghc-union-find")