summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-01-13 09:24:39 +0800
committer宋文武 <iyzsong@gmail.com>2016-01-16 08:18:37 +0800
commitc3e919d7a07dfe0b135eac8c2801d37587c47090 (patch)
tree4a2ccb894fdf89bb8238fb2d7e46b87ca914dcf0 /gnu
parente224b7d0bdfc58e251ba57f03c1ff74c7b4c2c62 (diff)
gnu: Add python-hy.
* gnu/packages/python.scm (python-hy, python2-hy): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ee6da2cdbf..cda995c440 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7057,3 +7057,30 @@ with a new public API, and RPython support.")
(define-public python2-rply
(package-with-python2 python-rply))
+
+(define-public python-hy
+ (package
+ (name "python-hy")
+ (version "0.11.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hy" version))
+ (sha256
+ (base32
+ "1msqv747iz12r73mz4qvsmlwkddwjvrahlrk7ysrcz07h7dsscxs"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-astor" ,python-astor)
+ ("python-clint" ,python-clint)
+ ("python-rply" ,python-rply)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "http://hylang.org/")
+ (synopsis "Lisp frontend to Python")
+ (description
+ "Hy is a dialect of Lisp that's embedded in Python. Since Hy transforms
+its Lisp code into the Python Abstract Syntax Tree, you have the whole world of
+Python at your fingertips, in Lisp form.")
+ (license license:expat)))
+
+(define-public python2-hy
+ (package-with-python2 python-hy))