summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:41 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:51 -0400
commitcc5e16a7645c9649154acb44ffdf486a088bd8bf (patch)
treedc7558b11fa9fb1a619fef4b50cd830ea59b3885 /gnu
parent67fa6ab5bb89efeabb5d5808d92b0e8085f91e9c (diff)
gnu: Add ghc-base16-bytestring.
* gnu/packages/haskell.scm (ghc-base16-bytestring): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 87628b559d..edb098a03f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6432,4 +6432,25 @@ can be specified precisely in the type. The language is closely related to
Epigram and Agda.")
(license license:bsd-3)))
+(define-public ghc-base16-bytestring
+ (package
+ (name "ghc-base16-bytestring")
+ (version "0.1.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/base16-bytestring/"
+ "base16-bytestring-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jf40m3yijqw6wd1rwwvviww46fasphaay9m9rgqyhf5aahnbzjs"))))
+ (build-system haskell-build-system)
+ (home-page "http://github.com/bos/base16-bytestring")
+ (synopsis "Fast base16 (hex) encoding and decoding for ByteStrings")
+ (description
+ "This package provides a Haskell library for working with base16-encoded
+data quickly and efficiently, using the ByteString type.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here