summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-05-11 18:24:53 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-11 18:29:39 +0200
commitcf60e76a9503156a8c1047fa446525b28842f7e8 (patch)
tree244267f46ba832f526906001ef9de2eeabb84038 /gnu
parent5d38aa082641ba99ff30e508393f33f6ca4789a1 (diff)
gnu: libxkbcommon: Move to (gnu packages xdisorg).
* gnu/packages/qt.scm (libxkbcommon): Move to... * gnu/packages/xdisorg.scm (libxkbcommon): ... here. New variable. * gnu/packages/wm.scm, gnu/packages/gnome.scm, gnu/packages/games.scm: Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm1
-rw-r--r--gnu/packages/gnome.scm1
-rw-r--r--gnu/packages/qt.scm38
-rw-r--r--gnu/packages/wm.scm1
-rw-r--r--gnu/packages/xdisorg.scm42
5 files changed, 41 insertions, 42 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a298f03512..75f926edce 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -93,6 +93,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages tcl)
#:use-module (gnu packages fribidi)
+ #:use-module (gnu packages xdisorg)
#:use-module (guix build-system trivial)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0fd1d5bb29..5169368562 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -93,7 +93,6 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages geeqie)
#:use-module (gnu packages gl)
- #:use-module (gnu packages qt) ; for libxkbcommon
#:use-module (gnu packages compression)
#:use-module (gnu packages texlive)
#:use-module (gnu packages tls)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7b2be4f4e9..097ec06d2a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -56,44 +56,6 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xml))
-(define-public libxkbcommon
- (package
- (name "libxkbcommon")
- (version "0.5.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://xkbcommon.org/download/" name "-"
- version ".tar.xz"))
- (sha256
- (base32
- "176ii5dn2wh74q48sd8ac37ljlvgvp5f506glr96z6ibfhj7igch"))))
- (build-system gnu-build-system)
- (inputs
- `(("libx11" ,libx11)
- ("libxcb" ,libxcb)
- ("xkeyboard-config" ,xkeyboard-config)))
- (native-inputs
- `(("bison" ,bison)
- ("pkg-config" ,pkg-config)))
- (arguments
- `(#:configure-flags
- (list (string-append "--with-xkb-config-root="
- (assoc-ref %build-inputs "xkeyboard-config")
- "/share/X11/xkb")
- (string-append "--with-x-locale-root="
- (assoc-ref %build-inputs "libx11")
- "/share/X11/locale"))))
- (home-page "http://xkbcommon.org/")
- (synopsis "Library to handle keyboard descriptions")
- (description "Xkbcommon is a library to handle keyboard descriptions,
-including loading them from disk, parsing them and handling their
-state. It is mainly meant for client toolkits, window systems, and other
-system applications; currently that includes Wayland, kmscon, GTK+, Qt,
-Clutter, and more. Despite the name, it is not currently used by anything
-X11 (yet).")
- (license (x11-style "file://COPYING"
- "See 'COPYING' in the distribution."))))
-
(define-public qt
(package
(name "qt")
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 694db4794a..1a0529c640 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -37,7 +37,6 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
- #:use-module (gnu packages qt)
#:use-module (gnu packages asciidoc)
#:use-module (gnu packages xml)
#:use-module (gnu packages m4)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 126e997673..e69e6d98d4 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,8 +54,8 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages xml)
#:use-module (gnu packages gtk)
- #:use-module (gnu packages qt)
- #:use-module (gnu packages xorg))
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages bison))
;; packages outside the x.org system proper
@@ -122,6 +122,44 @@ can also be used for copying files, as an alternative to sftp/scp, thus
avoiding password prompts when X11 forwarding has already been setup.")
(license license:gpl2+)))
+(define-public libxkbcommon
+ (package
+ (name "libxkbcommon")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://xkbcommon.org/download/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "176ii5dn2wh74q48sd8ac37ljlvgvp5f506glr96z6ibfhj7igch"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxcb" ,libxcb)
+ ("xkeyboard-config" ,xkeyboard-config)))
+ (native-inputs
+ `(("bison" ,bison)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-xkb-config-root="
+ (assoc-ref %build-inputs "xkeyboard-config")
+ "/share/X11/xkb")
+ (string-append "--with-x-locale-root="
+ (assoc-ref %build-inputs "libx11")
+ "/share/X11/locale"))))
+ (home-page "http://xkbcommon.org/")
+ (synopsis "Library to handle keyboard descriptions")
+ (description "Xkbcommon is a library to handle keyboard descriptions,
+including loading them from disk, parsing them and handling their
+state. It is mainly meant for client toolkits, window systems, and other
+system applications; currently that includes Wayland, kmscon, GTK+, Qt,
+Clutter, and more. Despite the name, it is not currently used by anything
+X11 (yet).")
+ (license (license:x11-style "file://COPYING"
+ "See 'COPYING' in the distribution."))))
+
(define-public xdotool
(package
(name "xdotool")