summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-24 21:16:29 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-24 21:16:29 +0200
commitd0dfc06683c868e48ee85213909e4013db94e221 (patch)
treefa12bc2a4bc538acd16b0f81b80708fe443b4c53 /gnu
parent10b1f68877b8198e0c1ab8b0ae9142f3b00975dd (diff)
gnu: ripperX: Update to 2.8.0.
* gnu/packages/mp3.scm (ripperx): Update to 2.8.0. Drop one patch and add another one. * gnu/packages/patches/ripperx-libm.patch: Remove file. * gnu/packages/patches/ripperx-missing-file.patch: New file. * gnu-system.am (dist_patch_DATA): Register one patch and unregister the other.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mp3.scm14
-rw-r--r--gnu/packages/patches/ripperx-libm.patch12
-rw-r--r--gnu/packages/patches/ripperx-missing-file.patch46
3 files changed, 53 insertions, 19 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 77eae65584..ddd90fb72a 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -355,18 +355,17 @@ use with CD-recording software).")
(define-public ripperx
(package
(name "ripperx")
- (version "2.7.3")
+ (version "2.8.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/ripperx/ripperx/"
- version "/ripperX-"
- version ".tar.gz"))
+ version "/ripperx-"
+ version ".tar.bz2"))
(sha256
(base32
- "130rsb2ly0l6hz728m9qr605ir4073xfl2acvf83id63kxfzjn3x"))
+ "1ss3c1a5hx6c99q1cryxg0jhbnbdj6ga9xyz0dzlz9qhzg5qswfs"))
(patches
- ;; see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713684
- (list (search-patch "ripperx-libm.patch")))))
+ (list (search-patch "ripperx-missing-file.patch")))))
(build-system gnu-build-system)
(propagated-inputs
`(("gs-fonts" ,gs-fonts)
@@ -377,7 +376,8 @@ use with CD-recording software).")
(inputs
`(("glib" ,glib)
("gtk+" ,gtk+-2)
- ("id3lib" ,id3lib)))
+ ("id3lib" ,id3lib)
+ ("taglib" ,taglib)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(synopsis "GTK program to rip and encode CD audio tracks")
diff --git a/gnu/packages/patches/ripperx-libm.patch b/gnu/packages/patches/ripperx-libm.patch
deleted file mode 100644
index 48277077cf..0000000000
--- a/gnu/packages/patches/ripperx-libm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r -u ripperX-2.7.3.old/src/Makefile.in ripperX-2.7.3.new/src/Makefile.in
---- ripperX-2.7.3.old/src/Makefile.in 2008-01-25 10:53:50.000000000 +0100
-+++ ripperX-2.7.3.new/src/Makefile.in 2013-08-07 16:14:21.000000000 +0200
-@@ -43,7 +43,7 @@
-
- ripperX_LDADD = \
- $(INTLLIBS) \
-- $(GTK_LIBS)
-+ $(GTK_LIBS) -lm
-
- AM_CPPFLAGS = \
- -DG_LOG_DOMAIN=\"ripperX\" \
diff --git a/gnu/packages/patches/ripperx-missing-file.patch b/gnu/packages/patches/ripperx-missing-file.patch
new file mode 100644
index 0000000000..6eb197fd7a
--- /dev/null
+++ b/gnu/packages/patches/ripperx-missing-file.patch
@@ -0,0 +1,46 @@
+This patch adds a header file that is present in the ripperx git and needed
+for inclusion, but missing in the distribution tarball.
+
+diff -u -r -N ripperx-2.8.0.orig/src/gtk_cpp_workaround.h ripperx-2.8.0/src/gtk_cpp_workaround.h
+--- ripperx-2.8.0.orig/src/gtk_cpp_workaround.h 1970-01-01 01:00:00.000000000 +0100
++++ ripperx-2.8.0/src/gtk_cpp_workaround.h 2015-07-24 21:09:16.548476337 +0200
+@@ -0,0 +1,39 @@
++#ifndef gtk_cpp_workaround_h
++#define gtk_cpp_workaround_h
++#ifdef __cplusplus
++//proto is wrong, override here for C++
++namespace
++{
++
++inline void gtk_table_attach (GtkTable *table,
++ GtkWidget *child,
++ guint left_attach,
++ guint right_attach,
++ guint top_attach,
++ guint bottom_attach,
++ //GtkAttachOptions xoptions,
++ //GtkAttachOptions yoptions,
++ guint xoptions, guint yoptions,
++ guint xpadding,
++ guint ypadding
++ )
++{
++ gtk_table_attach(table,
++ child,
++ left_attach,
++ right_attach,
++ top_attach,
++ bottom_attach,
++ (GtkAttachOptions)xoptions,
++ (GtkAttachOptions)yoptions,
++ xpadding,
++ ypadding
++ );
++
++ };
++
++
++}
++
++#endif
++#endif