summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-01-11 13:24:30 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-01-14 09:05:19 -0500
commite90051808badf801050c0034e5c045fec8aef6d2 (patch)
tree9a54c582b61d7efa77a47b274e831629d05d20fc /gnu
parent3141b83d4db74e226a7a6c8a608198128b3eee68 (diff)
gnu: Add version 2.7 variant of python-requests.
* gnu/packages/python.scm (python-requests-2.7): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4ab1eede6c..5f6ac799df 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2182,6 +2182,18 @@ compatible install in a way that is very close to the on-disk format.")
than Python’s urllib2 library.")
(license asl2.0)))
+;; Some software requires an older version of Requests, notably Docker
+;; Compose.
+(define-public python-requests-2.7
+ (package (inherit python-requests)
+ (version "2.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests" version))
+ (sha256
+ (base32
+ "0gdr9dxm24amxpbyqpbh3lbwxc2i42hnqv50sigx568qssv3v2ir"))))))
+
(define-public python2-requests
(package-with-python2 python-requests))